Home > android, tools > Workspace never loading in Eclipse

Workspace never loading in Eclipse

If you’ve been doing Android development for any length of time, you’ve no doubt experienced Eclipse getting stuck loading the workspace.

The symptoms are: you launch Eclipse, it starts to load, the progress bar in the launch window gets to about one third, and then it just sits there. Killing Eclipse.exe and starting over doesn’t help, it just happens again.

Here is a simple fix, found on stack overflow:

Open your workspace’s .metadata directory, then browse to .plugins\org.eclipse.core.resources and delete the file named .snap.

After this, the next time the workspace will load.

Advertisements
Categories: android, tools
  1. jim
    May 25, 2011 at 3:56 pm

    I have more issues with SVN hanging. Somedays its fine, somedays I have to delete the repository, some days I have to refresh…. Perhaps you could delve into that sometime 😉

    • May 25, 2011 at 4:11 pm

      I use Mercurial, and really like it. The Eclipse plugin has a couple of issues, but nothing I would call a show stopper. The stand-alone version has great Windows integration (highlights file / directory state right in the Explorer).

      Highly recommended. Supported by Google Code, too.

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s